Setting Proxy Internal + Mangle di Mikrotik

Salah satu feature proxy internal mikrotik yang bisa kita gunakan.Yah mungkin dah tau kan proxy ntu buat apaan.Saya ga akan membahas perbedaan/performance dengan software proxy lainnya.Rasakan, amati dan tentukan!
Ikuti Langkah2 dibawah ini dan thats it… so simple huh..
[g_locker type=”social”]
Script :
/ip proxyset enabled=yes
set src-address=0.0.0.0
set port=3128
set parent-proxy=0.0.0.0
set parent-proxy-port=0
set cache-administrator=”ifanetindonesia@yahoo.com”
set max-cache-size=noneset cache-on-disk=yes
set max-client-connections=600set max-server-connections=600set max-fresh-time=3dset always-from-cache=noset cache-hit-dscp=4
set serialize-connections=yes
Script :
/ip firewall natadd chain=srcnat out-interface=Internet src-address=192.168.11.0/24 action=masquerade
add chain=dstnat in-interface=Lokal src-address=192.168.11.0/24 protocol=tcp dst-port=80 action=redirect to-ports=3128
Script :
/ip firewall mangle
add chain=output out-interface=Lokal dscp=4 action=mark-packet new-packet-mark=proxy-hit passthrough=no comment=”HIT TRAFFIC FROM PROXY”
Script :
/ip firewall mangleadd chain=prerouting in-interface=Lokal src-address=192.168.11.0/24 action=mark-packet new-packet-mark=test-up passthrough=no comment=”UP TRAFFIC”
add chain=forward src-address=192.168.11.0/24 action=mark-connection new-connection-mark=test-conn passthrough=yes comment=”CONN-MARK”
add chain=forward in-interface=Internet connection-mark=test-conn action=mark-packet new-packet-mark=test-down passthrough=no comment=”DOWN-DIRECT CONNECTION”
add chain=output out-interface=Lokal dst-address=192.168.11.0/24 action=mark-packet new-packet-mark=test-down passthrough=no comment=”DOWN-VIA PROXY”
Script :
/queue tree
add name=”downstream” parent=Lokal packet-mark=test-down limit-at=32000 queue=default priority=8 max-limit=32000 burst-limit=0 burst-threshold=0 burst-time=0
sadd name=”upstream” parent=global-in packet-mark=test-up limit-at=32000 queue=default priority=8 max-limit=32000 burst-limit=0 burst-threshold=0 burst-time=0s
[/g_locker]
Semoga Bermanfaat

You may also like...

Popular Posts

Leave a Reply

Your email address will not be published. Required fields are marked *